Hardware Canucks

Hardware Canucks (http://www.hardwarecanucks.com/forum/)
-   Gaming (http://www.hardwarecanucks.com/forum/gaming/)
-   -   Battlefield Bad Company 2 - Graphics Glitching (http://www.hardwarecanucks.com/forum/gaming/29692-battlefield-bad-company-2-graphics-glitching.html)

TokeR March 9, 2010 08:52 PM

Battlefield Bad Company 2 - Graphics Glitching
 
I have had BC2 for a while now and just had time to play it today, but when I got into the game I realised there were some pretty serious looking glitches everywhere when explosions went off all there area where there would normally be smoke and white flashes of fire just flashed a glitchy looking black thing and walking through smoke made the entire screen flash black and a bunch of random colours really fast.

Is anyone else getting this?

I have tried on highest detail settings and lowest detail settings same effect.

Rig:

8800GTX
Intel Q6600 2.4GHz quad core CPU
4GB's of DDR2 Ram

Don't think it would be the rig I will check for new drivers now but I doubt it's that because I updated them only a few weeks ago...

Thanks for any help.

Perineum March 10, 2010 02:30 AM

Not here.... everything is fine on all machines....

cmac79 March 10, 2010 02:41 AM

fine for me as well

Technokat March 10, 2010 04:08 AM

fine for me, though i have once or twice had hills and terrain flash on and off like "pop in"

belgolas March 10, 2010 04:24 AM

100% fine for me.

Chromey March 10, 2010 04:59 AM

Make sure you remove all drivers Properly, Then reinstall.

Your system should be able to run this game Low to Mid, I cant see it going much higher.
Also Try a bigger res.

JD March 10, 2010 07:05 PM

Also if it's not a legit version, then maybe your issue lies there.

I had a possibly similar solution with the beta, but it would clear up after a few minutes of playing. Doesn't happen with the final release though.

Definitely sounds like a video card/driver related issue though.

TokeR March 14, 2010 03:53 AM

Quote:

Originally Posted by Chromey (Post 344875)
Make sure you remove all drivers Properly, Then reinstall.

Your system should be able to run this game Low to Mid, I cant see it going much higher.
Also Try a bigger res.

Underestimated my system lol, it's old but not that bad plays everything fine on High detail *now*

Quote:

Originally Posted by jdrom17 (Post 345230)
Also if it's not a legit version, then maybe your issue lies there.

I had a possibly similar solution with the beta, but it would clear up after a few minutes of playing. Doesn't happen with the final release though.

Definitely sounds like a video card/driver related issue though.

it's legit :thumb: STEAM purchased Just posting here to let everyone know what the problem was in case someone finds this thread on a Google search or something.

I downloaded the Latest Drivers for my card & restarted my computer everything is fine now.

Thanks for you help everyone.

Pelt March 14, 2010 04:41 AM

I had a similar problem not with the explosions showing up as black blobs, but with the screen flashing black during explosions or when firing my weapon. Don't know what caused the problem and I never did anything to fix it and the problems hasn't returned in the last few days of playing.

belgolas March 14, 2010 12:41 PM

Ya last night playing it a couple times the screen had black lines when an exposion happened. Never had a problem before but it hasn't come back. It was really hot in my room though as I was playing with a friend and had the door closed so we could turn up the volume.


All times are GMT -7. The time now is 07:38 AM.