Go Back   Hardware Canucks > HARDWARE > Display Units

    
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old February 17, 2010, 06:00 PM
JD's Avatar
JD JD is offline
Moderator
F@H
 
Join Date: Jul 2007
Location: Toronto, ON
Posts: 6,870

My System Specs

Default UltraSharp Return Policy?

I was chatting with Dell and the representative claims the following:
  • 30 days return policy, even if opened
  • No fees
  • No shipping costs (contact then and they'll send a box)
  • Dead pixels fully covered
So I want to confirm that with my fellow Canucks...

I can't find that in their policy, but maybe UltraSharps differ? Their policy is more along the lines of 30 days, unopened, pay taxes, shipping and possibly restocking fees.

I'm considering trying a 2709W, but I hear it has quite the input lag, so I might not end up liking it.
Reply With Quote
  #2 (permalink)  
Old February 18, 2010, 08:32 AM
Rookie
 
Join Date: Dec 2008
Location: Toronto
Posts: 39
Default

Quote:
Originally Posted by jdrom17 View Post
I was chatting with Dell and the representative claims the following:
  • 30 days return policy, even if opened
  • No fees
  • No shipping costs (contact then and they'll send a box)
  • Dead pixels fully covered
So I want to confirm that with my fellow Canucks...

I can't find that in their policy, but maybe UltraSharps differ? Their policy is more along the lines of 30 days, unopened, pay taxes, shipping and possibly restocking fees.

I'm considering trying a 2709W, but I hear it has quite the input lag, so I might not end up liking it.
I bought a 2709W from them around X-mas, can confirm to you that it's super easy to return and costs you nothing. You have 30 days from the day you receive it. If you want to return, and I did, just call them and they'll email you all the courier stuff. Just re-pack it and either call or drop off to UPS. Wait a few weeks and your credit card will be refunded for the full amount. Can't beat that. BTW I returned the 2709 rev A04 because of the input lag. It was bad. Mouse felt like it was moving through quicksand. I've been using a 3007WFP for a couple of years now, much better.

Cheers

PS They will try to make you keep it by offering you $100, $150 coupons for future orders. Just say no thanks.
Reply With Quote
  #3 (permalink)  
Old February 18, 2010, 02:53 PM
JD's Avatar
JD JD is offline
Moderator
F@H
 
Join Date: Jul 2007
Location: Toronto, ON
Posts: 6,870

My System Specs

Default

Input lag was that bad eh? I've never experienced it, so I have no idea how I'm going to feel about it.
Reply With Quote
  #4 (permalink)  
Old February 18, 2010, 02:57 PM
Thund3rball's Avatar
Hall Of Fame
 
Join Date: Nov 2007
Location: Vancouver
Posts: 3,526

My System Specs

Default

A friend of mine played monitor-go-round with 2407s a few years ago. I think they sent him like 4-5 displays before he stopped sending them back, lol. All at no extra cost. :)
__________________
"this is not troll. this is real deal!" - hohohee

Desktop:
See the drop down!

Laptop: Dell XPS M1530 \\ T7500 2.2GHz \\ 3GB 667 \\ 6 Cell \\ 8600M GT \\ 200GB 7.2K \\ WSXGA+ \\ Bluetooth/Wireless \\ MS Blue Track Mini \\ Vista Ult. (RED)


HEATWARE
Reply With Quote
  #5 (permalink)  
Old February 18, 2010, 03:51 PM
Rookie
 
Join Date: Dec 2008
Location: Toronto
Posts: 39
Default

Quote:
Originally Posted by jdrom17 View Post
Input lag was that bad eh? I've never experienced it, so I have no idea how I'm going to feel about it.
It's very personal. Some people don't notice it at all, some do.
Reply With Quote
  #6 (permalink)  
Old February 18, 2010, 04:18 PM
JD's Avatar
JD JD is offline
Moderator
F@H
 
Join Date: Jul 2007
Location: Toronto, ON
Posts: 6,870

My System Specs

Default

Quote:
Originally Posted by Rudel View Post
It's very personal. Some people don't notice it at all, some do.
Yeah so I hear. Average seems to be about 40ms, or 2.5-3FPS. I don't play anything competitively, nor do I consider myself a fast gamer (my friend for example is crazy), so I don't think it would be a huge deal in games. But if it's bad on the desktop too, then it could be an issue.

Curious, did you like it otherwise? And what connection were you using? Some claim VGA and DisplayPort have less lag.
Reply With Quote
  #7 (permalink)  
Old February 18, 2010, 04:50 PM
b1lk1's Avatar
Hall Of Fame
 
Join Date: Feb 2007
Location: Lindsay, Ontario
Posts: 2,482

My System Specs

Default

Had one and never noticed lag ever. Was a sick monitor.
__________________
MY HEATWARE
Reply With Quote
  #8 (permalink)  
Old February 19, 2010, 07:56 AM
Rookie
 
Join Date: Dec 2008
Location: Toronto
Posts: 39
Default

Quote:
Originally Posted by jdrom17 View Post
Yeah so I hear. Average seems to be about 40ms, or 2.5-3FPS. I don't play anything competitively, nor do I consider myself a fast gamer (my friend for example is crazy), so I don't think it would be a huge deal in games. But if it's bad on the desktop too, then it could be an issue.

Curious, did you like it otherwise? And what connection were you using? Some claim VGA and DisplayPort have less lag.
I think it has a lot to do with what you're using now and therefore what you're "used to." The 3007wfp has very low input lag and that's what I was using. I actually didn't notice it in games as much as I did moving the mouse around the desktop. Strange eh? I tried really hard to keep it but the mouse movement was driving me nuts.
Reply With Quote
  #9 (permalink)  
Old February 19, 2010, 12:48 PM
JD's Avatar
JD JD is offline
Moderator
F@H
 
Join Date: Jul 2007
Location: Toronto, ON
Posts: 6,870

My System Specs

Default

Yeah, I actually was reading some of your posts over on [H]. Right now I have the E228WFP or something like that, and apparently it has next to none input lag. So I imagine 40ms+ would be quite noticeable.

I'm actually considering this Acer 27" now that's a fair bit cheaper and TN-based so it should be fine lag wise. Not like I need super accurate colours anyhow.
Reply With Quote
  #10 (permalink)  
Old February 19, 2010, 06:36 PM
Rookie
 
Join Date: Dec 2008
Location: Toronto
Posts: 39
Default

Quote:
Originally Posted by jdrom17 View Post
Yeah, I actually was reading some of your posts over on [H]. Right now I have the E228WFP or something like that, and apparently it has next to none input lag. So I imagine 40ms+ would be quite noticeable.

I'm actually considering this Acer 27" now that's a fair bit cheaper and TN-based so it should be fine lag wise. Not like I need super accurate colours anyhow.
Yeah, I was really interested in that one as well. Some guy posted some pics at [H]. The 3007wfp is getting a little big for me. Sometimes I can't handle to small text. It sucks because there are really no return options for the Acer if you don't like it.
Reply With Quote
Reply


Thread Tools
Display Modes

Similar Threads
Thread Thread Starter Forum Replies Last Post
Asus Poor QA for LCD screens and stuck pixel policy atrocious JohnathanKong Display Units 1 November 23, 2009 11:57 AM
Components return rates Kilauea Reviews & Articles from the Web 18 October 24, 2009 06:29 PM
should I return it. Ken_C RAM 27 October 3, 2008 04:05 PM
EVGA shafts Canadian customers with new RMA policy werty316 Off Topic 42 December 18, 2007 10:07 PM
Dead Pixel Policy?? Prof. Dr. Silver Display Units 8 December 17, 2007 11:52 PM