Hardware Canucks

Hardware Canucks (http://www.hardwarecanucks.com/forum/)
-   CPU's and Motherboards (http://www.hardwarecanucks.com/forum/cpus-motherboards/)
-   -   MSI RMA in Canada (http://www.hardwarecanucks.com/forum/cpus-motherboards/63718-msi-rma-canada.html)

Masteroderus October 22, 2013 09:04 AM

MSI RMA in Canada
 
How easy/hard are these guys to deal with from Canada? I'm thinking of buying a MSI z87 mobo

Fudd Rucker October 22, 2013 09:20 AM

Last thing I RMA'd though MSI was a second hand GTX 470 I had gotten from a member here. The card was new from RMA. The process for me was quick and painless. They didn't require a receipt or anything. Took about 3 weeks total time which I thought was pretty good.

sswilson October 22, 2013 10:03 AM

Their GFX card RMA process is great, can't speak from personal experience WRT whether or not the MB RMA is carried out by the same folks.

Slaughter October 22, 2013 10:47 AM

I dealt with the local MSI office for a GPU RMA and I walked in and they just handed me another card.

crowTrobot October 22, 2013 01:33 PM

RMA'd mobo didn't take more than a week. I shipped it out to Markham, arrived there the next day, then two days later I got the notification that it has been shipped out already.

Rasparthe October 22, 2013 02:15 PM

One thing about MSI RMA is that they are quite good. If you live in the Markham area you can drop it off. I've dropped off a motherboard and before I got home I had a notice my RMA was shipped back to me. Can't beat that.

Masteroderus October 22, 2013 06:10 PM

Thanks guys :)

Delavan October 22, 2013 07:37 PM

MSI earned my respect after my 560Ti TFII OC RMA...

Quick turnaround, good card sent back, RMA'ed on serial number only, no receipt needed...

WILL BUY AGAIN!

sswilson October 22, 2013 07:40 PM

Quote:

Originally Posted by Delavan (Post 736203)
MSI earned my respect after my 560Ti TFII OC RMA...

Quick turnaround, good card sent back, RMA'ed on serial number only, no receipt needed...

WILL BUY AGAIN!

Yeah... that was my experience as well, unfortunately it was 4 times for the same set of two TFII cards......

They got bonus points for the ease of RMA, lost a few points for the fact that the TFII fans kept failing on me..... ;)

crowTrobot October 22, 2013 07:53 PM

^Same thing happened to my AM3 mobo, I eventually gave up after the second try (it was a different set of problem unrelated to the original RMA problem). The Z77 board still works like a charm though.


All times are GMT -7. The time now is 09:16 PM.