Go Back   Hardware Canucks > HARDWARE > CPU's and Motherboards

    
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old August 22, 2012, 02:26 PM
Gameman Advanced Kid
Guest
 
Posts: n/a
Default TF2 MVM server on pentium 3 SMP

please be serious. i really do need help and i am still poor because something is going on with that check that is suppose to be here already.

here are the specs of my server

Tyan S2518
x2 pentium 3 1.13ghz/512/133
1gb pc133

80gb main, 20gb gameservers


Internet Speed is 25mbps down 5mbps up.

the problem with the server is the FPS lag im getting. i was guessing the system didnt have enough ram so i added more as that did not fix the problem. i also tried cooling it and it did seem to run better but then went back to poo after i turnned off my house fan (i needed it back in my room).

the room its in is a bit hard to cool sometimes and i was thinking of moving the server here in my room and putting it on my client bridge router.

now should i upgrade the processors or buy new CPU fans?
Reply With Quote
  #2 (permalink)  
Old August 22, 2012, 06:14 PM
Allstar
 
Join Date: Aug 2011
Location: Vancouver, BC
Posts: 723
Default

If you removed a house fan and it went to crap, then time to clean the server case and see if any of the case fans are spinning slow or dead. Brand new CPU block and fan on Newegg is $5 so it's not too expensive to invest. I assume you never removed the CPU cooling block during the install? The heat paste may be dried out and need replacement. Unless you can find the 1.4Ghz for dirt cheap, no point in upgrading. Your old hardware can nickle and dime you to death if you insist on fixing them.
Reply With Quote
  #3 (permalink)  
Old August 22, 2012, 07:24 PM
BigPhatPaulie's Avatar
MVP
 
Join Date: Apr 2012
Location: Alberta
Posts: 439

My System Specs

Default

uh that connection doesnt sound nearly fast enough to run a server off of.... 5mbps upload is kinda low
__________________
FOR PONY..... that is alll
Reply With Quote
  #4 (permalink)  
Old August 23, 2012, 12:14 AM
Gameman Advanced Kid
Guest
 
Posts: n/a
Default

Quote:
Originally Posted by BigPhatPaulie View Post
uh that connection doesnt sound nearly fast enough to run a server off of.... 5mbps upload is kinda low
so would that be the cause of FPS lag? it was running fine before even when i resorted to the fan.

plus i need some 1u or 2u server fans for that machine since the fans on it are kind of small...
Reply With Quote
  #5 (permalink)  
Old August 23, 2012, 07:03 AM
BigPhatPaulie's Avatar
MVP
 
Join Date: Apr 2012
Location: Alberta
Posts: 439

My System Specs

Default

Well if its overheating that would be the issue
__________________
FOR PONY..... that is alll
Reply With Quote
  #6 (permalink)  
Old August 23, 2012, 09:38 AM
Gameman Advanced Kid
Guest
 
Posts: n/a
Default

do you know where i can get 1u or 2u coolers for the server then?
Reply With Quote
  #7 (permalink)  
Old August 23, 2012, 10:55 AM
Rookie
 
Join Date: Feb 2012
Location: Vancouver
Posts: 25
Default

Quote:
Originally Posted by BigPhatPaulie View Post
uh that connection doesnt sound nearly fast enough to run a server off of.... 5mbps upload is kinda low
Have to agree with this. Have a look at this table.
Reply With Quote
  #8 (permalink)  
Old August 23, 2012, 12:06 PM
Allstar
 
Join Date: Aug 2011
Location: Vancouver, BC
Posts: 723
Default

Just order them from Newegg if you're in US. There are not fans just for 1U or 2U, they are all measure by mm so you have to take out a ruler or Google the brand and make of the fans already in the case to figure out how big they are.
Reply With Quote
  #9 (permalink)  
Old August 23, 2012, 02:37 PM
Top Prospect
 
Join Date: Mar 2008
Posts: 62
Default

5mbps is probably enough for a MVM server (Which is max 6 physical players, although there is some additional bandwidth usage from the bots.)
EDIT: Make sure to turn off spectators so they aren't sucking up any bandwidth.

As has been mentioned, check what the cpu temperature is at under full load. This should be an easy and straightforward thing to rule out.

Otherwise, the thing I'd be looking at is the CPUs. SRCDS (Source Dedicated Server) is multi threaded, but the majority of the work takes place in a single thread (At least as of recently it used to. It is possible they updated it). Based on previous experience I doubt a 1Ghz P3 is fast enough to handle a SRCDS server, as especially with all the bots there is a lot of CPU calculations that take place. As an example, 2.4Ghz P4 era Xeons were not enough to handle very high tick rate 24 player CSS servers 5 years ago, and I suspect MVM has higher or similar requirements.

Memory might be another bottleneck later on once you resolve the cpu limitations.

Sum of the story, check what your cpu and memory utilization on the server is like. With how rate is tied into fps in the source engine, its very likely this is your issue.
__________________
We are shaped by fate, just as we shape it.
Reply With Quote
  #10 (permalink)  
Old August 23, 2012, 02:40 PM
Gameman Advanced Kid
Guest
 
Posts: n/a
Default

hm...i have had around 24 players on my HLDS servers once. i was also able to host multiple.

but in this case with source maybe that could be the reason...maybe not. because with 6 players it would need around 144kbps (or more).

it has run fine before but the fps lag just randomly came in.


im also doing some processor swaps and found that it gets hotter in then with the SL6by processors from my main desktop (the Dualatin). however im using the 1.13ghz processors from the server in the dualatin and its running like a champ. even the temps match so im guess that one of the SL6bys is defect because they have a high temp...i do have an sl657 laying around though so i already purchased another.

did i mention that my thumb feels really weird after using it to remove the heatsinks?(boy they are mean). they should have made teh socket tabs out of metal because i did have 1 break so far but i fixed it with epoxy. strong stuff \^u^/

anyway i am also looking on newegg and I FOUND A 1U COOLER ^^ Newegg.com - MASSCOOL 5R057B3 60mm Ball CPU Cooling Fan/Heatsink

i also did some more searching around on the internet looking to see if they made water cooling for socket 370 which they actually did but its now seldom to find any to buy on the internet.

anway ill be purchasing the coolers when i finally pry the check out of edward jones cold dead hands.
Reply With Quote
Reply


Thread Tools
Display Modes

Similar Threads
Thread Thread Starter Forum Replies Last Post
Possible file server/hosting server Mistertuxedopants New Builds 13 September 19, 2011 12:34 PM
Pentium G620 and Pentium G850 PerryC CPU's and Motherboards 4 July 29, 2011 05:36 AM
WIP Home File Server - Modding Rack mount Server Chassis CoolHandL Case Mods, Worklog & Gallery 24 December 22, 2010 11:37 AM
Pentium 4 file server Mr. Gruntsworthy New Builds 6 October 17, 2008 05:07 AM
Pentium Lives!! Pentium E2160 and Pentium E2140 Babrbarossa CPU's and Motherboards 4 June 4, 2007 04:25 AM