Go Back   Hardware Canucks > PC BUILDERS & TWEAKERS CORNER > Case Mods, Worklog & Gallery

    
Reply
 
LinkBack Thread Tools Display Modes
  #11 (permalink)  
Old June 27, 2008, 07:41 PM
3.0charlie's Avatar
3.0 "I kill SR2's" Charlie
F@H
 
Join Date: May 2007
Location: Laval, QC
Posts: 9,643

My System Specs

Default

Exactly - the hoses are not made for suction.
__________________
Hydro-Quebec is salivating...
Reply With Quote
  #12 (permalink)  
Old June 27, 2008, 07:52 PM
enaberif's Avatar
Hall Of Fame
 
Join Date: Dec 2006
Location: Calgahree, AB
Posts: 10,604
Default

Quote:
Originally Posted by 3.0charlie View Post
Exactly - the hoses are not made for suction.
hardline your case!
Reply With Quote
  #13 (permalink)  
Old June 27, 2008, 08:16 PM
JD's Avatar
JD JD is offline
Moderator
F@H
 
Join Date: Jul 2007
Location: Toronto, ON
Posts: 6,903

My System Specs

Default

Quote:
Originally Posted by enaberif View Post
how is performance for delivery and such? They got a few things I'd like.
Never had any major issues with them. Usually ships the day of or the day after you order. Just don't use UPS for shipping as you'll get hit with customs. USPS seems to be better though I think I'll probably still owe money since it was $200 order...
Reply With Quote
  #14 (permalink)  
Old June 28, 2008, 06:24 PM
JD's Avatar
JD JD is offline
Moderator
F@H
 
Join Date: Jul 2007
Location: Toronto, ON
Posts: 6,903

My System Specs

Default

Decided to drill the holes for the tubing and mock up the radiator as well:



Don't worry, those holes are going to be covered with some rubber edging. Now I sit here and patiently wait for my Performance-PCs order...
Reply With Quote
  #15 (permalink)  
Old July 2, 2008, 03:29 PM
JD's Avatar
JD JD is offline
Moderator
F@H
 
Join Date: Jul 2007
Location: Toronto, ON
Posts: 6,903

My System Specs

Default

Performance-PCs order came today

So here's the pump and reservoir setup. Hopefully it works...


Reply With Quote
  #16 (permalink)  
Old July 2, 2008, 08:21 PM
JD's Avatar
JD JD is offline
Moderator
F@H
 
Join Date: Jul 2007
Location: Toronto, ON
Posts: 6,903

My System Specs

Default

Triple post ftw

Mounted everything up to do some leak testing without clamps since they've yet to arrive. So far so good. Used about half a bottle of Fesser One.


Reply With Quote
  #17 (permalink)  
Old July 3, 2008, 09:39 AM
JD's Avatar
JD JD is offline
Moderator
F@H
 
Join Date: Jul 2007
Location: Toronto, ON
Posts: 6,903

My System Specs

Default

4th post

Updated the 1st post with final pictures. Temperatures to come...

As it stands, my idle temps are the same. Haven't yet put it under load yet.

The pump (MCP355) is rather noisy though. Hopefully its just because theres still more air...
Reply With Quote
  #18 (permalink)  
Old July 3, 2008, 10:46 AM
Top Prospect
 
Join Date: Nov 2007
Location: Edmonton, AB
Posts: 89
Default

good job!
I don't know if the mcp355 comes with a little neoprene pad like the mcp655 does, but if it does, I strongly recommend you use that. Using that pad brought my pump noise down a significant amount, because it made the whole case vibrate, causing this low noise that you could hear anywhere...
Reply With Quote
  #19 (permalink)  
Old July 3, 2008, 12:57 PM
JD's Avatar
JD JD is offline
Moderator
F@H
 
Join Date: Jul 2007
Location: Toronto, ON
Posts: 6,903

My System Specs

Default

Quote:
Originally Posted by nikitos View Post
good job!
I don't know if the mcp355 comes with a little neoprene pad like the mcp655 does, but if it does, I strongly recommend you use that. Using that pad brought my pump noise down a significant amount, because it made the whole case vibrate, causing this low noise that you could hear anywhere...
My pump is kinda suspended so it not really attached to anything other than the res.

The noise is actually due to all the air in my loop. Got most of it out now though and its a ton quieter.
Reply With Quote
  #20 (permalink)  
Old July 3, 2008, 10:11 PM
JD's Avatar
JD JD is offline
Moderator
F@H
 
Join Date: Jul 2007
Location: Toronto, ON
Posts: 6,903

My System Specs

Default

Some night pictures...


Long exposure:
Reply With Quote
Reply


Thread Tools
Display Modes