Go Back   Hardware Canucks > PC BUILDERS & TWEAKERS CORNER > Case Mods, Worklog & Gallery

    
Reply
 
LinkBack Thread Tools Display Modes
  #21 (permalink)  
Old February 15, 2011, 07:23 PM
Allstar
 
Join Date: Nov 2010
Location: London, Ontario
Posts: 644

My System Specs

Default

I got the beta assembled, will be painting fans and heatsink on friday if all goes as planned.

I also made the nice discovery that one of the fans was broken and two of the blades fell off. Sent a RMA to memoryexpress. If they're good they'll send me a replacement AP181 fan, if they're bad they'll deny me or request I send a 30lbs steel box back to them and loose a customer as I can go buy a AP181 somewhere else.
Attached Images
   
Reply With Quote
  #22 (permalink)  
Old February 15, 2011, 07:28 PM
CTA's Avatar
CTA CTA is offline
Hall Of Fame
 
Join Date: Jul 2008
Location: surrey (vancouver) bc canada
Posts: 2,012
Default

wow memoryexpress service sucks...

then you are really done?

i think you need to paint fan then you are done... ;p
__________________
---
NEW: customize case, hx100, i7 920, supreme hf, x58 sabertooth, 3gbx2 ram of ripjaws, xfx hd6950 CF. vertex 2 60gb, seagate and hitachi 1tb, dual mcp355 with ek rex v2, 2x koolance ar697, 2x mcr320, 6x zm-f3 fans.
OLD: cm 690, hx620, intel q9450, True Black, ga-ep45-ud3p, 2gbx2 ram of mushkin xp2 8500, xfx 285. wd caviar se16 640gb, 4x zm-f3 fans.
Reply With Quote
  #23 (permalink)  
Old February 15, 2011, 07:31 PM
Allstar
 
Join Date: Nov 2010
Location: London, Ontario
Posts: 644

My System Specs

Default

The noctua fans are getting a glossy white coat of kylon, the noctua itself is getting a black finish on the top fins and I have a MSI gtx 570 on the way to replace that cyclone 460 continuing with the black and white theme.

I also have some red cathodes I could put in but I don't think I will, I might pick up a couple whites ones though.
Reply With Quote
  #24 (permalink)  
Old February 15, 2011, 07:32 PM
Allstar
 
Join Date: Nov 2010
Location: London, Ontario
Posts: 644

My System Specs

Default

Quote:
Originally Posted by CTA View Post
wow memoryexpress service sucks...
Thats yet to be determined, waiting to see how they handle my RMA.
Reply With Quote
  #25 (permalink)  
Old February 17, 2011, 09:14 PM
Allstar
 
Join Date: Nov 2010
Location: London, Ontario
Posts: 644

My System Specs

Default

Alright, it's official.

The Raven02-e get a DO NOT BUY from me. The fans are all defective. The way the raven is designed the bottom AP181 fans hit their mount and break. I have to put them on rises as a second fan started to go.

I won't be buying another Silverstone product again after seeing them ship a built to fail design.
Reply With Quote
  #26 (permalink)  
Old February 17, 2011, 09:50 PM
coleo's Avatar
Top Prospect
 
Join Date: Jan 2011
Location: Edmonton
Posts: 128

My System Specs

Default

memory express wont help you out at all?
and just out of curiosity what do you mean built to fail?
my ap 181 fans are just fine and haven't had any problems

edit: what about silverstone themselves?
Reply With Quote
  #27 (permalink)  
Old February 17, 2011, 10:00 PM
Allstar
 
Join Date: Nov 2010
Location: London, Ontario
Posts: 644

My System Specs

Default

I RMA'd the broken fan to memoryexpress I expect they'll send me a new AP181.

As for silverstone the way the AP181s are mounted they hit against the mount and grill causing them to break. Apparently another user on newegg had the exact same thing. The fans NEED to be on risers from the grill.

It might just be the rv02-e revision but after inspecting this is a fatal flaw for the stock fans.

I emailed Silverstone about my problem I doubt they'll do anything as I can't RMA to them since I have one of the fans already sent out RMA to memexpress.

Last edited by jibz; February 17, 2011 at 10:05 PM.
Reply With Quote
  #28 (permalink)  
Old February 17, 2011, 10:25 PM
CTA's Avatar
CTA CTA is offline
Hall Of Fame
 
Join Date: Jul 2008
Location: surrey (vancouver) bc canada
Posts: 2,012
Default

serious?!

i have ss pb04... and not try it yet... >_>;

anyway sorry about your problems... but i think its good idea to replace stock fans.. with your trusty fan... ;p
__________________
---
NEW: customize case, hx100, i7 920, supreme hf, x58 sabertooth, 3gbx2 ram of ripjaws, xfx hd6950 CF. vertex 2 60gb, seagate and hitachi 1tb, dual mcp355 with ek rex v2, 2x koolance ar697, 2x mcr320, 6x zm-f3 fans.
OLD: cm 690, hx620, intel q9450, True Black, ga-ep45-ud3p, 2gbx2 ram of mushkin xp2 8500, xfx 285. wd caviar se16 640gb, 4x zm-f3 fans.
Reply With Quote
  #29 (permalink)  
Old February 17, 2011, 10:33 PM
Allstar
 
Join Date: Nov 2010
Location: London, Ontario
Posts: 644

My System Specs

Default

If your case comes with AP181s on rail mounts make sure they aren't screwed on too tight and preferably not horizontal...
Reply With Quote
  #30 (permalink)  
Old February 17, 2011, 10:38 PM
coleo's Avatar
Top Prospect
 
Join Date: Jan 2011
Location: Edmonton
Posts: 128

My System Specs

Default

have you got any pictures of this by chance?
I just want to know exactly what problem your having as i have the exact same case just in black
is it possible the dust filters are bent or warped and hitting the fans
Reply With Quote
Reply


Thread Tools
Display Modes

Similar Threads
Thread Thread Starter Forum Replies Last Post
[WTB] Black and or White Sleeving and Black Sata Cables CoolHandL Buy/Sell & Trade 0 August 27, 2010 01:08 PM
blu-ray plays in black and white only Kilauea HTPC Systems & Software 13 July 8, 2010 08:04 AM
Project: Black and White CanadaRox Case Mods, Worklog & Gallery 14 December 29, 2009 02:39 AM
why would my svideo out2 TV be black and white? Shadowmeph Troubleshooting 9 July 14, 2009 05:26 PM