Go Back   Hardware Canucks > HARDWARE > Audio

    
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old June 13, 2014, 06:23 PM
Fingercramps's Avatar
Rookie
 
Join Date: Nov 2012
Location: St. Paul, Minnesota
Posts: 44
Default Headset No Sound Issue

I've owned my Razer Megaladon for a a few years now, and its never gave me problems before other than a little static here and there when moving the wires a bit. The problem occurred right after I dropped the Audio Controller device that is attached to the cord on the ground. (Soft Carpet btw)

No big deal I've had this happen many times without any ill effect, not more than 5 minutes before I was listening to music crystal clear. I come back and there is no sound, obviously this disturbed me so I immediately went to my devices and checked the drivers, uninstalled them, rebooted my system and reinstalled the drivers. Still no change. So I go to sound options, disable, re-enable, and try all different USB ports, do the same driver fix I had tried before with rebooting and still no change.

I decided to try some different headphones thinking that I would at least be able to hear sound, but no even that was not yielding sound. All I can think of for solutions is to either try and purchase ANOTHER headset and test THAT out or see if its a problem with firmware. Any help or suggestions would be greatly appreciated.

*Note* I realize it could most obviously be because of dropping it on the floor, but since its been dropped many times beforehand on that carpet I would still like to at least hope it has some chance to live.
__________________
“Opposition always enflames the enthusiast, never converts him.”
Reply With Quote
  #2 (permalink)  
Old June 14, 2014, 03:13 AM
KaptCrunch's Avatar
Hall Of Fame
 
Join Date: Feb 2008
Location: Ontario
Posts: 2,955
Default

need to open the box to re-solder broken connection while apart replace cord with better stuff
Reply With Quote
Reply


Thread Tools
Display Modes

Similar Threads
Thread Thread Starter Forum Replies Last Post
Odd Headset Issue AlanMatt Troubleshooting 3 December 12, 2013 11:53 AM
Need help with sound card + headset The Great ImageFap Troll Audio 25 January 14, 2012 11:20 AM
New headset & Sound card Maarten200 Audio 7 November 9, 2011 05:20 PM
bad headset or bad onboard sound? Remoth Audio 8 May 24, 2010 09:38 PM
Headset and sound card Shiverwarp Audio 15 July 31, 2007 07:30 AM