Go Back   Hardware Canucks > HARDWARE > Audio

    
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old October 1, 2011, 04:33 PM
Rookie
 
Join Date: Sep 2011
Posts: 11
Default Logitech X-530's popping

Generally when listening to music, playing games and watching movies all satellites make a popping sound and this has only started to happen. Also I should mention that this happens infrequently and i am worried about my $100 AUD investment. I have tried using different players for music and videos with no luck. I am using a USB to 5.1 external sound card from Zalman.

All opinions are welcome.
Reply With Quote
  #2 (permalink)  
Old November 19, 2011, 09:11 PM
Rookie
 
Join Date: Dec 2008
Location: Sarnia ON Canada
Posts: 25

My System Specs

Default

Have you reinstalled or updated your audio drivers ?
Reply With Quote
  #3 (permalink)  
Old November 20, 2011, 05:58 PM
ultraman7k's Avatar
Allstar
 
Join Date: Oct 2009
Location: Surrey, B.C.
Posts: 527

My System Specs

Default

How old are the speakers? This happened with my old Logitechs back in the day. Wasnt long before I had to trash them.
Reply With Quote
  #4 (permalink)  
Old November 21, 2011, 08:57 AM
JimboToronto's Avatar
Top Prospect
 
Join Date: Jul 2009
Posts: 173

My System Specs

Default

Have you tried the speakers with another sound source other than your computer?

A popping noise sounds more like a soundcard/driver issue than faulty speakers.

I've been using Logitech speakers since replacing my old Klipsch ProMedias with Z560s and the only problem I've ever had was a dirty potentiometer.
Reply With Quote
  #5 (permalink)  
Old November 23, 2011, 07:31 AM
Lsv's Avatar
Lsv Lsv is offline
Top Prospect
 
Join Date: Nov 2011
Location: Toronto/GTA
Posts: 58

My System Specs

Default

Try your sound card, same instances in just headphones or alternative speakers. If you hear the popping it's the PC/Sound card. Maybe latency is too low for what you want or the card has hardware issues.

If you don't notice anything try the speakers on an iPod or some other source, same material if you can and check for pops. None of these generic speakers are shielded very well nor do they have great power management. It's very possible a capacitor is failing and upon releasing stored energy it sends too much and pops. My older M-Audio BX5s did this simply because of cheap parts.

Hope you get your sound up and running!
__________________
i7 920 (no oc) w/ Noctua NH-D14
Asus P6T
Asus 6950 DC II 2gb
12gb G.Skill Ripjaws 1600mhz
Intel X-25M 80gb Gen2
1x WD Caviar Green 1TB 64m cache
Native Instruments Komplete Audio 6
Seasonic X-660
Fractal Design R3 + 4x Noctua S12B 120mm
Reply With Quote
  #6 (permalink)  
Old November 25, 2011, 02:30 AM
Hall Of Fame
F@H
 
Join Date: Jan 2007
Location: Scarborough
Posts: 1,437

My System Specs

Default

Do they all pop? If not, try switching them around. It's unlikely all the speakers will go at the same time. Use your motherboard's onboard audio to test them. I've been using refurbished X-540's for a few years now with no problems.
__________________


EBAY(http://myworld.ebay.ca/scott0639)
Reply With Quote
  #7 (permalink)  
Old November 25, 2011, 06:43 PM
Dr_BenD_over's Avatar
Fallen Folder
F@H
 
Join Date: Jul 2008
Location: Nova Scotia
Posts: 2,418

My System Specs

Default

My Z-640's just started doing the same thing, I'm gonna dissect then on Sunday and see where the trouble lies (it's not the PC, headphones plugged into the PC - A-OK, plugged into the Z-640's, SNAP Crackle POP) Probably a blown/bad cap or something.
__________________
All's well that's Haswell
Reply With Quote
Reply


Thread Tools
Display Modes

Similar Threads
Thread Thread Starter Forum Replies Last Post
Xonar Essence STX - Crackling/Popping EypheQz Audio 7 January 9, 2011 04:07 AM
Creative X-Fi Titanium popping and stuttering Kovok Troubleshooting 13 May 2, 2010 12:32 PM
Unable to reformat pc, error keeps popping up! ezytgr O/S's, Drivers & General Software 11 March 17, 2010 10:24 PM
Popping and cracking on integrated sound chrisk Troubleshooting 9 March 22, 2009 11:27 AM
AVG notice just started popping up saying it's discontinued.... Misoprostol O/S's, Drivers & General Software 19 January 6, 2008 09:12 AM