View Single Post
  #1 (permalink)  
Old June 27, 2013, 08:36 AM
frozenskipper frozenskipper is offline
Top Prospect
 
Join Date: Oct 2011
Location: Rjukan, Norway
Posts: 59

My System Specs

Default No boot whatsoever

It started some time ago when my Sabertooth P67 seemingly died on me. I simply shut down my computer, and when i tried to start it the day after, nothing happened. All i got was my fans spinning for half a second, then nothing. No beep code, no red LED's, no nothing.

I tried troubleshooting in many many ways and asking around on forums, and eventually figured it had to be my motherboard that had failed.

I sent it back to my retailer who declined return because the board was "Physically damaged".



I though screw them then, and ordered a z77 sabertooth from another retailer and hoped this would be the solution. I just received it, placed it on a cardboard box, hooked everything up; 8 pin, 24pin, single RAM dimm, CPU and cooler, and when i went to short the power switch pins, guess what?

The fans spun for half a second then nothing. Only a single green LED at the bottom. Not even a beep code. I have also tried to reset the CMOS.



Anyone had similar experiences? It's frustrating the hell outta me...

Shouldn't be a PSU issue. Have tried both the XFX and my old Chieftec.
Reply With Quote