View Single Post
  #18 (permalink)  
Old April 5, 2013, 08:03 PM
great_big_abyss's Avatar
great_big_abyss great_big_abyss is offline
Hall Of Fame
F@H
 
Join Date: Oct 2011
Location: Winnipeg
Posts: 2,258

My System Specs

Default

Okay, so I played a game with my brother and one of his friends. Annihilated them, lol. I played a LOT of this game, so glad to know I still have it.

Anyways, I have to say I'm disappointed with the 'HD' version of the game. It doesn't seem like an improvement at all over the original. I think I just got hosed for $18, especially when you consider that I've owned the original for something like 14 years. Heck, they didn't even clean up the menu interface or make multiplayer any easier to navigate. It all feels very 'nineties'.

There isn't even an option that I saw to change the resolution or graphics settings (but let's be honest, what machine these days wouldn't be able to run it?) That being said, it hitched a few times on my rig. Weird!

Well, I'll probably play it a few times, and I have no idea where my original disc went, so I guess I'll get my money's worth out of it.

Still disappointed.
__________________



HTPC: Z77A-G45; 3770K; Corsair H80i; 2x4GB Kingston HyperX 1600Mhz; MSI GTX960; 2x 128GB Crucial M4 SSD; 4TB WD Red, 2x 2TB WD Green; Corsair RM650I; Corsair Carbide 600C;
Son's Rig: M5A97; 1055T; CNPS20LQ; 2x4GB Corsair Vengeance 1600Mhz; Powercolor 7950; 250GB Crucial MX200; 320GB WD Black HDD; SPI 700W; Bitfenix Shinobi;
Reply With Quote