View Single Post
  #1 (permalink)  
Old January 5, 2013, 10:07 AM
NyteOwl's Avatar
NyteOwl NyteOwl is offline
Allstar
 
Join Date: Aug 2008
Location: Nova Scotia
Posts: 905
Default Unusual behaviour from expansion card

I just installed a Silverstone SST-EC05 card in my X48 based box. This is a PCIe x1 SATA III 2 port card based on the Marvel 9130.

Plugged it into a slot (x4 though it shouldn't matter) started the system (XP SP3 up to date) and it was found no problem and the usual request for drivers. Installed the drivers from the supplied CD, pointed Windows at them and after installing them I get a message that the driver installation couldn't be completed because the drivers were corrupt.

So, I uninstalled the drivers, uninstalled the card from device manager, removed the card, reran the driver installation routine, reinstalled the card and XP gave me the same error. I tried downloading the latest version from Silverstone's website and tried again. Same thing. (I also got a message from WinZIP that the driver file failed CRC check on extraction - even on repeated attempts)

Uninstall everything again. This time I tried a set of drivers from MSI's site (I really wish Marvell would post them on their own website). Same message from Windows though the archive extracted cleanly.

I sent an e-mail to Silverstone who said the firmware was corrupt and to exchange the card.

While waiting to arrange this the first of the week, and figuring I couldn't create any more problems, I uninstalled everything again, swept any trace from the registry of previous attempts and grabbed what seemed to be the newest drivers of of station-drivers.com.

This time it seemed to work. XP accepted the drivers without a hic-cup and installed the card fine. I haven't connected a drive to it yet. but so far so good. Not sure if I should trust the new arrangement or take Silverstone's advice and return the card. Maybe see what happens after I try a drive on it I guess.

Anyone ever encountered such behaviour?
__________________
Obsolescence is just a lack of imagination.

Last edited by NyteOwl; January 5, 2013 at 10:10 AM. Reason: Fixed typos
Reply With Quote