View Single Post
  #10 (permalink)  
Old December 23, 2012, 03:53 AM
MAK MAK is offline
Top Prospect
 
Join Date: Jan 2009
Posts: 90
Default

I suspect it may be the WDTV too... but I agree with the others who say the router isn't the best. I'd never trust that router - there isn't even a plug for an external antenna. I wonder what the range of the wireless is...

I can't help with the WDTV side of things.. I don't have one of those. But for the router:

The router may have been working great with the iPhone - especially if it was running slow (it may have connected as 802.11g or even 802.11b which is much slower than the new 802.11N). You may not have noticed the slow speed or if the connection hiccups occasionally.

But if you are trying to stream a movie (especially HD) you will need the 802.11N speed, and you want it to be as error free as possible (no dropped connection, then reconnect etc...).

Try some of the following:
1. See if it is the wireless' fault. Get (or borrow) a network cable long enough to go from your router to the WDTV and see if it works any better. (Perineum tried that and it didn't work, you should test it too.) Bear in mind that that router does not have wired Gigabit support (another reason I don't like it) but a wired 100Mb connection should be more than enough for HD.

2. Move the router closer to the WDTV. Maybe its the range you get with the router's internal antenna. It shouldn't be closer than half a meter, though. Try getting the two devices a few meters apart and see if that helps.

3. Check your wireless security. Are you using older encryption like WEP ? (I hope not, but I'd better ask). Some routers will drop down to wireless G speeds if you use WEP...change it to WPA.

4. Change the wireless channel. This happened to a friend of mine (interference from a neighbour) and a simple change of the channel cleared up the air, so to speak.

5. Borrow a newer router from someone (if you can) and test it out. That might solve the problem. If it does, then you might decide to buy another router or try to fix your firmware.

6. (this is very technical and may be irreversible) Try changing the firmware on the router to something like DD-WRT or Tomato. This may solve some problems, maybe even give you better Wireless N performance, but it is a lot less 'user friendly' than the firmware that came with the router. You will end up looking through the online help and wikis if you want to set up and configure your router with one of these open source firmware. I'd recommend you ask around for help on this one, and see if it helped anyone else with the same router model.


Hope this helps a bit.

[edit] I just found the support page for the router (here) and under "dropping/intermittent connectivity" there's one more thing you can try: turn off Upnp (I guess it would be off anyway).

Last edited by MAK; December 23, 2012 at 04:02 AM. Reason: Added more data.
Reply With Quote