View Single Post
  #8 (permalink)  
Old September 6, 2012, 03:20 PM
JD's Avatar
JD JD is offline
Moderator
F@H
 
Join Date: Jul 2007
Location: Toronto, ON
Posts: 6,951

My System Specs

Default

The GTX690 is not really the right card for 1080p though...

Have you tried doing a driver wipe? Drive Sweeper does a pretty decent job. I'd check off both ATI and NVIDIA options, while running in safe mode. Then install the latest beta NVIDIA drivers.

Also check in the NVIDIA control panel that there's no v-sync stuff enabled. Maybe Adaptive V-Sync is on by default?
Reply With Quote