View Single Post
  #4 (permalink)  
Old July 23, 2012, 04:06 AM
Mnemonic Mnemonic is offline
Rookie
 
Join Date: Jul 2012
Posts: 4
Default

Looks like i may have solved the issue.

I decided to have a go at downgrading the bios to an older version.
I started with version 1.40 downloaded from the Asrock site.
Flashed the bios from within windows and restarted the pc.
I did expect my main monitor to blank out with my small number two monitor (pdf reader) to remain on as I had this one connected to the Intel onboard dvi.
Low and behold the main monitor fire up immediately!
I went straight into the bios and checked the northbridge settings for the pcie link speed.
It was now sitting at AUTO which is normal but in this instance the 7850 had been detected successfully.

I booted into windows and then flashed the bios to 1.80 expecting the board to die again, but nope it booted and detected the 7850 again!
Third times the charm, booted to windows and flashed to 2.00 (the latest at the time of writing) and voila...still working.

Next I disabled the power management function in windows 7 for pcie and fired up gpu-z.
GPU-z still showed the card at pciex16 1.1.
So i ran the render test to see if the card would ramp up and it did successfully did so reading pciex16 3.0 under load.

Woot!
I hope this helps someone else.
Now i'm about to conduct one last test; reset the cmos and see if the bios recovers.
Wish me luck.
Reply With Quote