View Single Post
  #27 (permalink)  
Old June 8, 2012, 06:32 PM
steve123 steve123 is offline
Trial Member
 
Join Date: Jun 2012
Posts: 1
Default HOW TO RECOVER DATA From DEAD HARD DRIVE

I have a black "SELECT IOMEGA" 1TB External Portable USB 2.0 Hard Drive. I tried plugging in directing (Front and Back of USB ports) into 3 different desktop computers and trying all 2.0 USB ports available. All 3 computers does NOT detecting the Iomega. And it does NOT show on the "my computer" screen. And it does NOT show in the "Drive Manager" as well. I also tried another USB ''Y" cable and it did NOT work. When I plugged it in, the power light on the drive is lit green, which means it getting power through. But, I can Not feel a buzzing/vibrating or spinning inside the Iomega drive. I'm using XP and Windows 7. I just want my data back. Is Iomega motor Dead? Should I try "Freezing It", Take it Apart, open it using Adapter Tools: "USB to SATA/IDE". ANY IDEAS? ADVISE? PLEASE HELP.
Thank you..

Last edited by steve123; June 8, 2012 at 07:18 PM. Reason: add
Reply With Quote