View Single Post
  #8 (permalink)  
Old May 14, 2012, 06:05 PM
deinosaur's Avatar
deinosaur deinosaur is offline
Top Prospect
 
Join Date: Jun 2011
Location: London, Ontario, Canada
Posts: 61

My System Specs

Default

Quote:
Originally Posted by frontier204 View Post
I looked at WD's return policy and they say nothing about what they'll do with your data, except:

WD Support / Warranty Services / End User / Packaging and Shipping Instructions
From that it shows they won't even try to get into your data unless someone's really interested, or something clearly visible on the HDD sparks a police investigation...

It sounds like the power connector / cord to your external enclosure is to blame, although I wouldn't advise you try to test that thing again unless you know how to handle faulty electronics. My guess is from the shock you received - that for sure means something's up with the grounding of the enclosure, or you were dragging your feet with wool socks on carpet for a couple minutes before touching the enclosure...

As for backtracking the failure, I'd look at anything that connects to the hard drives, starting with power supply cables, power supply, then data cables, then whatever may be on the other side of the data cables.
Thank you very much for looking into it for me. I also tried to find anything relating to that in their policies and had no luck. I have hardwood floors and normal Hanes socks lol so that probably isn't it. The power supply SHOULD be fine... since everything else that is connected to it is working perfectly. Do you think it could be the Cosmos II hotswap enclosure? This is the very first place that I put the hard drives after they stopped working. and the External Enclosure worked for me with the now fried 2TB hard drive about 2 days before getting the Cosmos II. I am not good with electronics or even know how to test them in a detailed manner, but I am tempted to stick a 36GB raptor into the hotswap area and see if that hard drive gets murdered. I have 2 of these that I know work ... hmmmm.

Western Digital also instantly approved the RMA and I have them packed up and ready to go. I just need to find the source of the problem now so this never happens again.
Reply With Quote