View Single Post
  #1 (permalink)  
Old April 18, 2012, 04:17 PM
LM89 LM89 is offline
Rookie
 
Join Date: Apr 2012
Posts: 2
Default Something wrong with my Cases power button?

I just finished my new build a few days ago and immediately ran into problems trying to power it on. It works for only about 2 seconds and then it shuts everything off, the fans, the LED lights everything runs but then it shuts itself off after 2 seconds. I must have tried 30 times switching it on and off and I probably only managed to get it to boot all the way once or twice.

So of course I did the usual troubleshooting steps of reseating everything including my motherboard, ram, and heatsink I also checked for bent pins and I didn't find anything wrong. Finally I just decided to move the reset switch header of the case on to the pins where the power switch header is normally supposed to go. It worked, the computer was able to boot up properly and consistently. I turned it on and off many times to double check, and it booted up properly each time. So I switched back the power switch header back to it's normal placement thinking everything's fixed, I fire it up and it still doesn't work.

I've sent the case back to my local NCIX store asking them for a replacement since I'm still under their 30 day warranty, but of course first they had to check and see if it was indeed faulty. I got a call back from them today saying that they couldn't find anything wrong with the power button and that they've tested it with the volt meter or something. They suggested that there could be something wrong with my motherboard.

My question is could my motherboard possibly be screwed up? or could it simply be that I have a faulty power switch on my new case? I'm leaning more towards the latter honestly. I would like to hear what you guys think.

My build:
NZXT Phantom 410 case
Asus p8z68-v gen3 motherboard
Mushkin Enhanced Ridgeback Redline 16gb ram
XFX 750W PSU
NH-D14 heatsink
Reply With Quote