View Single Post
  #11 (permalink)  
Old November 30, 2011, 07:37 PM
Your_friendly_gamer's Avatar
Your_friendly_gamer Your_friendly_gamer is online now
Allstar
F@H
 
Join Date: Nov 2010
Location: Ottawa
Posts: 693

My System Specs

Default

Quote:
Originally Posted by martin_metal_88 View Post
If you get mad that fast and stop buying a brand because they found fix you have fail to do. You wont be buying any comptuer hardware really soon.
Gigabyte have some of the best successfull RMA out there, so many brand ship defective board or fail to even find a problem on the mobo.
Next time before starting to bitch at some company maybe you could wait to see if they fixed the problem? Because now you will only look like an idiot if it was really a bios problem.
LOL do you work for gigabyte? Have you ever called their customer support? One you pay out of your pocket to get help, and 2nd you are getting really really shitty support. No one ever has a clear answer.

I think you maybe missing the point and or a gigabyte fanboy, which is fine.

When I asked them which version they used to fix the issue, they said the latest, the latest is from last year? And when I tried to get more answers, there werent any.

So I will get the same board back maybe with some out of this world bios or some special bios Captain Chris talked about and it would be fixed.

As far as customer support and getting feedback and or getting notifications, they really do suck, I am terribly sorry to upset you.
Reply With Quote