View Single Post
  #28 (permalink)  
Old November 23, 2011, 12:59 AM
bugmenot bugmenot is offline
Rookie
 
Join Date: Feb 2010
Posts: 6
Default

Quote:
Originally Posted by Writer View Post
The problem you're running into is network throttling. Vista and Win7 have a feature that automatically throttles inbound network throughput whenever there is multimedia playback. This is done so the network overhead won't interfere with your media playback, but that would only be the case on a very, VERY slow system.

On a modern gaming or HTPC this feature makes no sense.

At least it's easy to modify or disable: just change the value of this registry key:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Multimedia\SystemProfile\Network ThrottlingIndex

By default it's 10, which means reduce inbound bandwidth to 10% during multimedia playback.

Some guides recommend setting it to 40. I set it to >= 100 on all my PCs.

Setting it to any value of 100 or larger will disable the throttling. (Microsoft says to use 0xffffffff or -1 to disable it, but it's internally treated as an unsigned value so that's just another way of setting it to a value that is larger than 100.)

See How to use the throttling mechanism to control network performance in Windows Vista for more on this "feature."

Note that this only affects inbound bandwidth; you only need to change the setting on the local system where you're viewing the file, not the remote one that is hosting the file.
I would like to thank you for this fix. It has been bugging me but as soon as I applied it, it was working perfectly. Thank you again!
Reply With Quote