View Single Post
  #1 (permalink)  
Old September 27, 2011, 05:37 PM
Linus's Avatar
Linus Linus is offline
 
Join Date: Apr 2007
Posts: 716
Default System won't boot up - Tried RMAing the PSU already and still not working

This is a question from tienflame:

Quote:
Hi linus im sorry for wasting your time but i just have a question i wanted to ask if you can help me solve this computer problem i have. I have been watching your videos for years and i finally saved up enough money to built my own gaming p.c.

I have just finish building it and did all the wire management but there is a problem of my computer not turning on. I thought it might have been a power supply problem and i did an RMA on the power supply but it still wouldnt turn on after i install the new psu.

I have no idea what to do now please if you can help! thank you

Also i have a
990 FX sabertooth MB
AX 850 PSU
8gb of G skill ripjaws series Ram
msi n560 twin frozr 2
H 70 liquid cooler
So are you getting any lights or fans spinning up at all? Have you checked to ensure that all power connectors are plugged in?

If you're still getting absolutely no response from the system, my best guess would be motherboard since you've already RMAed your power supply once. The odds of two dead PSUs in a row are very remote.
__________________
Please note: I am not here to provide official NCIX support on these forums.

For faster (and official) NCIX service please contact our customer care team at www.NCIX.com (Canada) or www.NCIXUS.com (USA)

Heatware: http://heatware.com/eval.php?id=25647
Reply With Quote