View Single Post
  #1 (permalink)  
Old February 7, 2011, 08:24 PM
patrick_kidd patrick_kidd is offline
Rookie
 
Join Date: Feb 2011
Posts: 3
Default Sapphire HD 6870 - Display driver has stopped responding and successfully recovered

This happens every time I try to play Tf2, the witcher, or L4D2. So as soon as any of these games get past the loading screen to actually enter a game (or server loading screen in tf2/l4d2), The screen will flicker to black, the fans in my case stop momentarily, and the games crash giving the error Hl2.exe has had an error... If I do this in windowed mode, the bottom gives an error saying "Driver ati driver has stopped responding and has successfully recovered" This happens every time.

This is a new pc I just built, and has been doing so since I started trying to run these games. There had been one time where TF2 and the witcher both worked, and that was after I installed Dirt 2 (and Directx 11 was installed on my system). They then proceeded not to work after I tweaked my ram settings in the bios (and reverted).

Specs are as follows:

amd phenom ii x4 970
ASUS M4A79T Deluxe
SAPPHIRE 100314SR Radeon HD 6870
SAMSUNG Spinpoint F3 HD502HJ 500GB 7200 RPM 16MB Cache SATA 3.0Gb/s 3.5" Internal Hard Drive
G.SKILL Ripjaws Series 4GB (2 x 2GB) 240-Pin DDR3 SDRAM
LITE-ON Black 24X DVD+R
CORSAIR CMPSU-750TX 750W ATX12V
Antec Three Hundred Black Steel ATX Mid Tower Computer Case
ASUS VH236H Black 23" 2ms(GTG)
Windows 7 64bit ultimate.



Things I've done so far to try and fix:

Stripped out all video drivers and reinstalled them about a dozen times (including using a driver sweeper on some passes)

Prevented windows from auto installing drivers when none are present (to make sure it doesn't do so while I install official ones)

Installed drivers from original Dvd and official site

Over clock, Under clock, Change idle core/memory clock, turn up fan

Flash bios to newest version

Overclock ram/return to normal speeds

Run memtest86 (0 errors returned)

Tried playing with default windows drivers (not amd official)

I'll post if I remember anything else. Also these game swere tried with a fresh DL from steam, all come up validated and defragged.

I can run Dirt2 at 1920 x 1080 at ultra settings w/ full antialiasing and anistrophic filtering, so I don't believe the card is over heating. I've also bench tested it in MSI Kombustor, and it runs just fine.

Anyone have any ideas?? This is really killing me because I don't want to return the card since I have seen that it offers some great performance...
Reply With Quote