View Single Post
  #1 (permalink)  
Old January 11, 2011, 08:08 PM
Mr. Gruntsworthy's Avatar
Mr. Gruntsworthy Mr. Gruntsworthy is offline
Join Date: Sep 2008
Location: Courtice, ONT
Posts: 743
Default Internet Speed confusion and NAT problems have me in a tizzy.

Hi, all. I've been having a slew of strange shenanigans with my internet and NAT settings. Lemme provide the set up.

My Internet Service: Rogers Express Hi-Speed Internet. 9 Mbps download/512kbps upload
Location: Oshawa, Ontario
Router: LinkSys Wireless-N Broadband router, WRT160N firmware 3.0

Beforehand, I've always had extremely slow/nonexistent access to the internet while running BitComet or other torrent software; while active, I was always slow to load web pages, and sometimes I was completely blacked out from anything else on my computer accessing the internet while it was running (such as MSN, web browsers, Steam). After closing Bitcomet, my internet would always be slow afterwards, until it seemingly cleared up a day or two later each time.

Then, one day, I notice the notification about my Listen Port in the bottom of Bitcomet; yellowed to say it's blocked. After much f***ing around to figure out what's going on, I determined that the only way to clear the listening port was to reboot my router. (Even restarting my computer wouldn't clear the listening port). Sometimes I can run Bitcomet two or three times before it starts getting blocked, but most often I only need to run it once and the next time I go to open it the listening port is blocked.

Fast forward to a week ago. Getting sick of this frustration, I ran a few tests on The result averaged out at about 4.5mbps download. (this was after having run bitcomet the day before, and not rebooting my router quite yet).

I phoned in to rogers customer support, and after rebooting my modem and my router, I ran the speedtest again. I found out that SOMEHOW, after rebooting my router and modem, I was getting TWICE the download speed I should be! Let me reiterate; I only pay for 9 megabytes a second download; my speedtest was hitting anywhere from 18mbps to 21mbps every time. Even Roger's own speedtest showed the same result. The rogers guy told me to keep quiet about the speeds... Anyways, after I reboot my router, I somehow enjoy twice my specified download speed until I start up bitcomet, and then I get throttled all the way back down to 4.5mbps, sometimes even 3.5. Whenever I try to play games online after using bitcomet and before rebooting my router, I always lag.

Now, all of a sudden, my Xbox 360 game Halo Reach's built-in NAT detector warned me that my NAT is now set to Moderate, rather than Open like it's always been. Which is strange, since I haven't changed ANY settings in my router, or updated it.

I'm getting fed up with my network's incompetence... I personally think that the moderate NAT settings, the throttled internet, and the blocked listening port in bitcomet are all connected.

So, I turn to you guys in hopes of sorting this stuff out. You did me the favor of reading that wall of text, so the least I can do is organize the questions...

1) Why do I get throttled back to 50% or lower of my paid internet speed during, and after, running Bitcomet? Is it Rogers? Is it my Router?

2) Is there any way to stop the throttle so that I don't have to manually reboot my modem and router every time I run Bitcomet? Preferrably also fixing the Listening Port problem I mentioned?

3) How do I manage twice my internet speed after manually rebooting my modem and router?

4) What could cause my NAT settings to change like this, all of a sudden? How can I set it back to Open, if at least for my Xbox 360?

5) Could the cause of this be my router? Is it known to have problems?

Right now, I'm going to upgrade the firmware (if possible) and see if that fixes the issue.

ANY input you guys might have on the matter is much appreciated :)
Case: CoolerMaster HAF 932
CPU : Intel i7-5820K 6-core @ 3.3GHz
RAM : 32GB DDR4 2400MHz (G.SKILL Ripjaws)
HDD : Main: 240GB SSD SATA2 (Intel) Storage: 3TB SATA2 (WD Green) Backup: 500GB External USB (Hitatchi)
GFX : Gigabyte GTX 970 4GB
PSU : 750W Corsair Modular PSU
MoBo: Asus X99-A
View : Acer H213H 21.5" @ 1920 x 1080 + random 4:3 monitor

Level/Game Designer, Programmer
Reply With Quote