Thread: Stereo Receiver
View Single Post
  #19 (permalink)  
Old October 16, 2010, 07:17 AM
sswilson's Avatar
sswilson sswilson is online now
Moderator
F@H
 
Join Date: Dec 2006
Location: Moncton NB
Posts: 14,223

My System Specs

Default

Quote:
Originally Posted by 3.0charlie View Post
Now, it's all your fault Cam. Since I replied in this thread, I started digging into the world of used components...

Sold the Naim amp.
Sold the Energy Connoisseurs.
Bought a Rotel amp, on its way from Saskatoon.
And I'm going to pick up a pair of Mission 701s this morning.
Though I'm keeping the LP12.

Vive the English sound!

If you haven't already heard these speakers in action, I don't think you'll be disapointed. My young lad had a set that came bundled with an older Pioneer HT amp I purchased and they sounded great, right up until he blew them by cranking the I/P voltage to his amp (using PC as source) which (best guess) produced enough dirty power to the speakers that they finally gave up the ghost.

Somebody around here as a set they've put up for sale on kijiji, and I've been considering picking them up.
__________________
EVGA X58 3X SLI / i7 980X / 3X 4G Mushkin Blackline Frostbite / XFX Pro 1000W / EVGA GTX 680 SC+ 2GB / Intel DC S3700 200G / WD 6401AALS / TT Lvl 10 GT
Swiftech MCP655 WC Pump / EK XT 240 Rad / 2X Scythe Ultra Kaze / EK Supreme HF / Primochill Myriad Dual Bay Res / Dell UltraSharp U2412M

Gigabyte C1007UN-D / 2X4G Gskill PC3-10700 / Pico PSU / 2.5" 750G Toshiba HDD / Mini-Box M350 / 1X 19" BenQ / 1X 17" HP
Reply With Quote