View Single Post
  #41 (permalink)  
Old March 18, 2010, 12:05 PM
Posts: n/a

Originally Posted by Fudd Rucker View Post
LMAO what driver problems? So far the only driver issues ive ran into that 7 itself didnt have a pretty decent driver for already was bluetooth and ancient wireless cards. I have installed windows 7 on at least 200 machines without a single issue. Get less obscure or modern hardware as ive had laptops from 2007 install everything right out of the box. My macbook pro even had every device installed and ready to go out of the box when I ran windows 7 on it for gaming.

Granted Linux is free - its impractical for your average schmoe. And installing drivers via linux can be outright retarded and over the top complicated for no reason with shit driver support at best as they chop proper support for VGA especially after a single generation, yet you complain about windows and your "8" drivers. Granted almost all motherboards now use roughly either 1 of 3 chipsets - AMD,Nforce, Intel x38/x48/x58/P55 - almost all of those drivers install out of the box.Then there is the matter of audio/video/NIC which has a pretty small competition base so even then the driver base isnt all that big.Ive also installed windowss on many many pcs with your specs that didnt require that insane amount of drivers- unless your one of those who has to make everything a lot more difficult then it has to which a lot of backyard techs do to make themselves seem a lot more skilled then they actually are. That also goes a lot for those blatantly ignorant Linux users who try wow people with thier uber console skills which is so much more practical then simple double clicking.

Then there is a big part of an OS which many still cling on too gaming - why else would we have this kickass hardware?
Gaming is pisspoor at best with linux. Wine is buggy as crap doesnt work all that well. Crossover is crap, and CVS cedega is an optimized version of WINE.

Linux is great if you have one specific task in mind or production in mind. Not practical anymore for everyday home use.

Look at my system specs:

Amount of drivers needed to install - 1 - ATI CCC, oh and RAID drivers when I did initial install. Everything after install out of the box has worked flawlessly for me. Zero crashing, zero problems.

Now if I were using linux I would have to make sure my xorg was configured right then....

Obtaining Needed Software

Before you begin, it is strongly advised that your already have Xorg working acceptably with the 'nv' drivers included.

First, make sure that your /etc/X11/xorg.conf is backed up. sudo cp /etc/X11/xorg.conf /etc/X11/xorg.conf.backup
Next, download the right drivers for your platform from the driver download page or the NVIDIA Unix Driver portal and save them to your home directory.
Open a terminal, and run the following command: sudo apt-get install build-essential linux-headers-`uname -r`
This next step is optional. Most people will not need it, and it takes a fair amount of bandwidth and diskspace. It installs the Linux kernel source. If later steps fail, consider this a last resort.

sudo apt-get install linux-source-`uname -r`cd /usr/srcsudo tar xvjf linux-source-`uname -r`sudo ln -s linux-source-`uname -r` /usr/src/linux
The above command might print an error similar to the following: E: Couldn't find package linux-source-2.6.20-16-386
In such case you could try following sudo apt-get install linux-source
The following command will then probably need adjustment also.
Disable Conflicting Software

Using Synaptic or apt-get, uninstall nvidia-glx, nvidia-glx-legacy, nvidia-glx-new and nvidia-settings if they are installed.
Open the the /etc/default/linux-restricted-modules-common file with an editor, in Ubuntu use gksudo gedit /etc/default/linux-restricted-modules-common
and in Kubuntu use kdesu kate /etc/default/linux-restricted-modules-common
and find the line: DISABLED_MODULES=""
replace it with: DISABLED_MODULES="nv nvidia_new"
Note: In Ubuntu 7.04 the nvidia_new is explicitly required in addition to nv on the DISABLED_MODULES line. See this launchpad bug about lrm-manager failing to disable the nvidia_new module when nv is specified alone. Additionally you may need to manually remove the hidden /lib/linux-restricted-modules/.nvidia_new_installed file.
Warning: Be wary of uninstalling nvidia-kernel-common or packages starting with the name linux-restricted-modules. Doing so will cause all restricted drivers to be uninstalled which may result in other hardware (e.g. certain wireless cards) or other software (e.g. VMware) failing to work after a reboot/kernel update.

Prepare Configuration Files

The next step is to edit your xorg.conf file. This may not be needed in Hardy Heron and newer, but check anyway, esp. if you have upgraded from older versions of Ubuntu.
In Ubuntu: gksudo gedit /etc/X11/xorg.conf
Or in Kubuntu: kdesu kate /etc/X11/xorg.conf
Find the section Module and comment out DRI using the # symbol, such as in the following example. Section "Module" Load "bitmap" Load "dbe" Load "ddc"# Load "dri" <------ this is 'commented' Load "extmod" Load "freetype" Load "glx" Load "int10" Load "record" Load "type1" Load "vbe"EndSection
Now find the section Device, and change the Driver from nv (or vesa, fb, etc) to nvidia, as in the following example, and then save it. Section "Device" Identifier "Card0" Driver "nvidia" #This is where you change itEndSection
Now that your Xorg.conf is saved, we need to shutdown the X11 server so that we can install the new drivers. To do this, save your work and press ctrl-alt-f1, and log in. Then run the following command to shutdown X11. Make sure your work is saved, Gnome/KDE is going to shutdown too.
For Ubuntu: sudo /etc/init.d/gdm stop
For Kubuntu: sudo /etc/init.d/kdm stop
Install the Driver

Useful tip, typing the first few letters and hitting the Tab key will auto-complete the name, saving you from using wildcards like *
First navigate from the tty to the directory where you saved the install file (I will use /path/to/installer), then set executable permissions on it: cd /path/to/installersudo chmod +x NVIDIA*
You can start the install script with the following command: sudo sh NVIDIA*
The installer will now walk you through the steps required. Assuming success, you can now restart your X11 server using:
For Ubuntu: sudo /etc/init.d/gdm start
For Kubuntu: sudo /etc/init.d/kdm start

You can now change settings for your video setup. In Ubuntu, go to Applications->System Tools->NVIDIA X Server Settings (or sometimes System->Administration->NVIDIA X Server Settings depending on the driver and/or install method). Alternatively, use the terminal:
For Ubuntu: gksudo nvidia-settings
For Kubuntu: kdesu nvidia-settings
For setting up dual head, see NvidiaMultiMonitors.
Load driver on boot

The X server will start in low-resolution if the nvidia driver is not loaded on boot, so $ sudo gedit /etc/modules and add a line containing nvidia
Kernel and Mesa Updates

Every time a new kernel comes out you will probably have to manually rebuild the NVIDIA binary driver kernel module. This can be done by booting to the new kernel and then running: sudo sh NVIDIA* -K
on the previously downloaded NVIDIA installer file.
Additionally, any time that the mesa packages are updated you will have to reinstall the NVIDIA .pkg again.
Uninstalling the Driver

Sometimes it is necessary to uninstall the driver, like before a version upgrade of Ubuntu or if the installation fails or is no longer needed. For a manual install, you can remove the driver using the installer file: sudo sh NVIDIA* --uninstall
You will probably be asked to reboot the computer.
It didn't work! (Troubleshooting)

When trying to start X, if you get an error about nvidiactl (you will need to see the X log), try the following:
  • sudo update-rc.d -f nvidia-kernel remove
If you want to go back to the Restricted Manager method after performing the above instructions, do this
  • sudo update-rc.d nvidia-kernel defaults
If the installer fails, go through the following checklist
  • Was Xorg already properly configured for the nv driver?
  • Did you disable the loading of Ubuntu provided NVIDIA drivers using DISABLED_MODULES="nv nvidia_new" in /etc/default/linux-restricted-modules-common ? This is a common cause of driver mismatch errors on manual installations due to conflicts with the Ubuntu provided NVIDIA binary driver.
  • You may need to remove the file /lib/linux-restricted-modules/.nvidia_new_installed
  • Did you remove the nvidia-glx/nvidia-glx-legacy/nvidia-glx-new and nvidia-settings packages?
  • Did you read the log found in /var/log/nvidia-installer-log for errors that can guide you?
  • Did you check the output of dmesg ?
  • Did you install the kernel headers (and possibly source package)?
  • Did you check the NVIDIA readme found on their site to make sure your card is supported with that version of driver?
  • Did you check the NVIDIA Linux Forums for any current 'known issues' with the latest drivers?
  • Did you ask in #ubuntu on or any of the other places mentioned on ?
Because those instructions above is soooooooo much easier and reliable right?
I'll flame you for off-top and flooding the site with copy-paste

Average shmoe is better off with linux. At least when he doesn't know the su password, nothing can be done to mess up the box :). Realistically, I had convinced 5 people to *try* to switch, including my sister. All but one were non-technical, and yet every one could not find any issues running linux. Most used it for what computers were meant to do though - actual, real work, not games.

Sounds like you had a helluva time installing nv driver for linux. Sure sounds funny how a proprietary piece of software is such a pin in the butt to install. No, wait, I did not read your post carefully enough - I am convinced you have never tried linux, since you plain copy-pasted all the cautions from NV's linux driver page (or did you actually go to ubuntu forums? I applaud if you did). Ubuntu 7.04 (Feisty Fawn) was the give-away, as I used its beta exactly 3 years ago. For a comparison, go to ATi's linux driver page, and tell me if it is much different from the windows driver. Also, do you not have to completely remove the Forceware drivers on windows when upgrading the driver? Good luck with that! You have to use Detonator RIP to completely remove nv drivers from windows; in linux, using Synaptic (not that you know what it is), search for nvidia, and deselect all installed, hit "Apply", done! In W7, in order to install the ATi graphics driver, I had to download and install (manually, mind you!) the latest version of .net framework. WTF??? That should be driver #9, and a completely useless one at that too.

To install the only driver I had to on linux, I clicked on
System -> Administration -> Hardware Drivers (not that hard to follow, is it?)
One driver was there, coloured grey as not enabled (the nvidia driver when I had my 8800 GT, obviously it is the CCC now that I got the ATi card). I clicked on it to select it, then hit "Activate", input password to authorise such a major change to the OS. Waited 3 minutes for download and install, then rebooted when prompted. Ran compiz after reboot, and installed Doom 3. Don't know exactly how much simpler it can get really.

Ubuntu 10.04 comes with 3-d accelerated OSS drivers for both ATi and NV FYI. Performance wise, they are, ahem, could be better, but more then enough for casual desktop effects and an odd 3D game. In a year or two, the performance will be on par with the proprietary drivers, then you truly won't need to do any further work.

With W7 on my machine... Here are the drivers needed
1 - Wifi driver (took forever to find the driver CD, then W7 couldn't find the Vista driver automatically, then I had to force the driver installation) (No need on linux)
2 - ATi driver (See above)
3 - LAN driver (No need on linux, I don't use wired NIC anyhow though)
4 - printer driver (Cupsys recognised my NX415 as soon as it was turned on)
5 - Audio drivers (I had sound, but front panel did not work)
6 - TV tuner card (No need on linux)
7 - CPU drivers (to enable on-demand frequency scaling, does that out of the box on linux)
8 - Monitor driver (No real need, but it was not showing the highest 3 MP resolution)

I fail to see how exactly wine is linux' problem. It does something linux is not meant to do, and you bitch at linux for wine being buggy? Wine is used in all *NIX systems for windows compatibility, including your OSX, not just linux, perhaps you should also bitch at Apple for wine not working 100% like windows. It works better with old software than your W7 BTW.
Reply With Quote